$re = '/\[\[File:[^[\]]*(?:\[\[[^[\]]*]][^[\]]*)*]]/';
$str = 'Some [[File:Edvac.jpg|thumb|[[EDVAC]], one of the first stored-program computers]] text';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;