re = /\[\[File:[^[\]]*(?:\[\[[^[\]]*]][^[\]]*)*]]/
str = 'Some [[File:Edvac.jpg|thumb|[[EDVAC]], one of the first stored-program computers]] text'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result