use strict;
my $str = 'Some [[File:Edvac.jpg|thumb|[[EDVAC]], one of the first stored-program computers]] text';
my $regex = qr/\[\[File:[^[\]]*(?:\[\[[^[\]]*]][^[\]]*)*]]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";