import Foundation
let pattern = #"\[\[File:[^[\]]*(?:\[\[[^[\]]*]][^[\]]*)*]]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Some [[File:Edvac.jpg|thumb|[[EDVAC]], one of the first stored-program computers]] text"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)