const regex = /\[\[File:[^[\]]*(?:\[\[[^[\]]*]][^[\]]*)*]]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\[File:[^[\\]]*(?:\\[\\[[^[\\]]*]][^[\\]]*)*]]', 'g')
const str = `Some [[File:Edvac.jpg|thumb|[[EDVAC]], one of the first stored-program computers]] text`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);