#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*(?<!\.min)\.js$"
Local $sString = "client/bower-components/angular-datatables/dist/angular-datatables.js" & @CRLF & _
"client/bower-components/angular-datatables/dist/angular-datatables.min.js" & @CRLF & _
"client/bower-components/angular-datatables/dist/plugins/bootstrap/angular-datatables.bootstrap.js" & @CRLF & _
"client/bower-components/angular-datatables/dist/plugins/bootstrap/angular-datatables.bootstrap.min.js" & @CRLF & _
"client/bower-components/datatables/media/css/jquery.dataTables.min.css"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")