$re = '/^.*(?<!\.min)\.js$/m';
$str = 'client/bower-components/angular-datatables/dist/angular-datatables.js
client/bower-components/angular-datatables/dist/angular-datatables.min.js
client/bower-components/angular-datatables/dist/plugins/bootstrap/angular-datatables.bootstrap.js
client/bower-components/angular-datatables/dist/plugins/bootstrap/angular-datatables.bootstrap.min.js
client/bower-components/datatables/media/css/jquery.dataTables.min.css';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);