import Foundation
let pattern = #"^.*(?<!\.min)\.js$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
client/bower-components/angular-datatables/dist/angular-datatables.js
client/bower-components/angular-datatables/dist/angular-datatables.min.js
client/bower-components/angular-datatables/dist/plugins/bootstrap/angular-datatables.bootstrap.js
client/bower-components/angular-datatables/dist/plugins/bootstrap/angular-datatables.bootstrap.min.js
client/bower-components/datatables/media/css/jquery.dataTables.min.css
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)