import re
regex = re.compile(r"^.*(?<!\.min)\.js$", flags=re.MULTILINE)
test_str = ("client/bower-components/angular-datatables/dist/angular-datatables.js\n"
"client/bower-components/angular-datatables/dist/angular-datatables.min.js\n"
"client/bower-components/angular-datatables/dist/plugins/bootstrap/angular-datatables.bootstrap.js\n"
"client/bower-components/angular-datatables/dist/plugins/bootstrap/angular-datatables.bootstrap.min.js\n"
"client/bower-components/datatables/media/css/jquery.dataTables.min.css")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")