re = /^.*(?<!\.min)\.js$/m
str = 'client/bower-components/angular-datatables/dist/angular-datatables.js
client/bower-components/angular-datatables/dist/angular-datatables.min.js
client/bower-components/angular-datatables/dist/plugins/bootstrap/angular-datatables.bootstrap.js
client/bower-components/angular-datatables/dist/plugins/bootstrap/angular-datatables.bootstrap.min.js
client/bower-components/datatables/media/css/jquery.dataTables.min.css'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end