const regex = /^.*(?<!\.min)\.js$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(?<!\\.min)\\.js$', 'mg')
const str = `client/bower-components/angular-datatables/dist/angular-datatables.js
client/bower-components/angular-datatables/dist/angular-datatables.min.js
client/bower-components/angular-datatables/dist/plugins/bootstrap/angular-datatables.bootstrap.js
client/bower-components/angular-datatables/dist/plugins/bootstrap/angular-datatables.bootstrap.min.js
client/bower-components/datatables/media/css/jquery.dataTables.min.css`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}