import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*(?<!\\.min)\\.js$";
final String string = "client/bower-components/angular-datatables/dist/angular-datatables.js\n"
+ "client/bower-components/angular-datatables/dist/angular-datatables.min.js\n"
+ "client/bower-components/angular-datatables/dist/plugins/bootstrap/angular-datatables.bootstrap.js\n"
+ "client/bower-components/angular-datatables/dist/plugins/bootstrap/angular-datatables.bootstrap.min.js\n"
+ "client/bower-components/datatables/media/css/jquery.dataTables.min.css";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}