#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(\d{4})(\d{2})(\d{2}) (\d{2}:\d{2}).*"
Local $sString = "20130603 00:00:03.102" & @CRLF & _
"20130703 00:01:03.103" & @CRLF & _
"20130804 00:03:03.104"
Local $sSubst = "\1-\2-\3 \4:00"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)