using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4})(\d{2})(\d{2}) (\d{2}:\d{2}).*";
string substitution = @"\1-\2-\3 \4:00";
string input = @"20130603 00:00:03.102
20130703 00:01:03.103
20130804 00:03:03.104";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}