package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(\d{4})(\d{2})(\d{2}) (\d{2}:\d{2}).*`)
var str = `20130603 00:00:03.102
20130703 00:01:03.103
20130804 00:03:03.104`
var substitution = "\1-\2-\3 \4:00"
fmt.Println(re.ReplaceAllString(str, substitution))
}