import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4})(\\d{2})(\\d{2}) (\\d{2}:\\d{2}).*";
final String string = "20130603 00:00:03.102\n"
+ "20130703 00:01:03.103\n"
+ "20130804 00:03:03.104";
final String subst = "\\1-\\2-\\3 \\4:00";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}