// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(\d{4})(\d{2})(\d{2}) (\d{2}:\d{2}).*").unwrap();
let string = "20130603 00:00:03.102
20130703 00:01:03.103
20130804 00:03:03.104";
let substitution = "\\1-\\2-\\3 \\4:00";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}