import Foundation
let pattern = #"(\d{4})(\d{2})(\d{2}) (\d{2}:\d{2}).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
20130603 00:00:03.102
20130703 00:01:03.103
20130804 00:03:03.104
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1-\2-\3 \4:00"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)