$re = '/(\d{4})(\d{2})(\d{2}) (\d{2}:\d{2}).*/im';
$str = '20130603 00:00:03.102
20130703 00:01:03.103
20130804 00:03:03.104';
$subst = "\1-\2-\3 \4:00";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;