use strict;
my $str = '20130603 00:00:03.102
20130703 00:01:03.103
20130804 00:03:03.104';
my $regex = qr/(\d{4})(\d{2})(\d{2}) (\d{2}:\d{2}).*/imp;
my $subst = '\\1-\\2-\\3 \\4:00';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";