#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([a-zA-Z ]*)([0-9]*)"
Local $sString = "ANIL AGARWAL : \n09331015728\n09830050442\nMAYANK AGARWAL : \n09836516042" & @CRLF & _
"Amit Singh :\nChakmir 9013477227\n\nHitendra Singh:\n\nM. : 9674918943"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")