const regex = /([a-zA-Z ]*)([0-9]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z ]*)([0-9]*)', 'g')
const str = `ANIL AGARWAL : \\n09331015728\\n09830050442\\nMAYANK AGARWAL : \\n09836516042
Amit Singh :\\nChakmir 9013477227\\n\\nHitendra Singh:\\n\\nM. : 9674918943`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}