package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-zA-Z ]*)([0-9]*)`)
var str = `ANIL AGARWAL : \n09331015728\n09830050442\nMAYANK AGARWAL : \n09836516042
Amit Singh :\nChakmir 9013477227\n\nHitendra Singh:\n\nM. : 9674918943`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}