import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z ]*)([0-9]*)";
final String string = "ANIL AGARWAL : \\n09331015728\\n09830050442\\nMAYANK AGARWAL : \\n09836516042\n"
+ "Amit Singh :\\nChakmir 9013477227\\n\\nHitendra Singh:\\n\\nM. : 9674918943";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}