$re = '/([a-zA-Z ]*)([0-9]*)/';
$str = 'ANIL AGARWAL : \\n09331015728\\n09830050442\\nMAYANK AGARWAL : \\n09836516042
Amit Singh :\\nChakmir 9013477227\\n\\nHitendra Singh:\\n\\nM. : 9674918943';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);