re = /([a-zA-Z ]*)([0-9]*)/
str = 'ANIL AGARWAL : \\n09331015728\\n09830050442\\nMAYANK AGARWAL : \\n09836516042
Amit Singh :\\nChakmir 9013477227\\n\\nHitendra Singh:\\n\\nM. : 9674918943'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end