import Foundation
let pattern = #"([a-zA-Z ]*)([0-9]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ANIL AGARWAL : \n09331015728\n09830050442\nMAYANK AGARWAL : \n09836516042
Amit Singh :\nChakmir 9013477227\n\nHitendra Singh:\n\nM. : 9674918943
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)