using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z ]*)([0-9]*)";
string input = @"ANIL AGARWAL : \n09331015728\n09830050442\nMAYANK AGARWAL : \n09836516042
Amit Singh :\nChakmir 9013477227\n\nHitendra Singh:\n\nM. : 9674918943";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}