#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[.*?(\d*?),.*?(\d*?),.*?(\d*?),.*?(\d*?)\]"
Local $sString = "C9: Title of object (foo, bar) [ch1, CH12,c03,4]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")