const regex = new RegExp('\\[.*?(\\d*?),.*?(\\d*?),.*?(\\d*?),.*?(\\d*?)\\]', '')
const str = `C9: Title of object (foo, bar) [ch1, CH12,c03,4]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}