// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[.*?(\d*?),.*?(\d*?),.*?(\d*?),.*?(\d*?)\]").unwrap();
let string = "C9: Title of object (foo, bar) [ch1, CH12,c03,4]
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}