$re = '/\[.*?(\d*?),.*?(\d*?),.*?(\d*?),.*?(\d*?)\]/';
$str = 'C9: Title of object (foo, bar) [ch1, CH12,c03,4]
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);