import Foundation
let pattern = #"\[.*?(\d*?),.*?(\d*?),.*?(\d*?),.*?(\d*?)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
C9: Title of object (foo, bar) [ch1, CH12,c03,4]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}