use strict;
my $str = 'C9: Title of object (foo, bar) [ch1, CH12,c03,4]
';
my $regex = qr/\[.*?(\d*?),.*?(\d*?),.*?(\d*?),.*?(\d*?)\]/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}