package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[.*?(\d*?),.*?(\d*?),.*?(\d*?),.*?(\d*?)\]`)
var str = `C9: Title of object (foo, bar) [ch1, CH12,c03,4]
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}