using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[.*?(\d*?),.*?(\d*?),.*?(\d*?),.*?(\d*?)\]";
string input = @"C9: Title of object (foo, bar) [ch1, CH12,c03,4]
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}