# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/case ("[a-z]")/case $1c/gm;t' <<< "case \"c\"
case \"B\""