import re
regex = re.compile(r"case (\"[a-z]\")", flags=re.MULTILINE)
test_str = ("case \"c\"\n"
"case \"B\"")
subst = "case $1c"
result = regex.sub(subst, test_str)
if result:
print(result)