// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)case ("[a-z]")"#).unwrap();
let string = "case \"c\"
case \"B\"";
let substitution = "case $1c";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}