use strict;
my $str = 'case "c"
case "B"';
my $regex = qr/case ("[a-z]")/mp;
my $subst = 'case $1c';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";