import Foundation
let pattern = #"case ("[a-z]")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
case "c"
case "B"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"case $1c"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)