$re = '/case ("[a-z]")/m';
$str = 'case "c"
case "B"';
$subst = "case $1c";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;