$re = '/\"postcode\"\:\"(?<postcode>[^\"]+)\"/';
$str = '{"line1":"1 THE STREET","line2":"TOWN","line3":"CITY","line4":null,"postcode":"AB11AB","country":"GREAT BRITAIN","startDate":944697600000,"type":"Residential"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);