import re
regex = re.compile(r"\"postcode\"\:\"(?<postcode>[^\"]+)\"")
test_str = "{\"line1\":\"1 THE STREET\",\"line2\":\"TOWN\",\"line3\":\"CITY\",\"line4\":null,\"postcode\":\"AB11AB\",\"country\":\"GREAT BRITAIN\",\"startDate\":944697600000,\"type\":\"Residential\"}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")