re = /\"postcode\"\:\"(?<postcode>[^\"]+)\"/
str = '{"line1":"1 THE STREET","line2":"TOWN","line3":"CITY","line4":null,"postcode":"AB11AB","country":"GREAT BRITAIN","startDate":944697600000,"type":"Residential"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end