// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\"postcode\"\:\"(?<postcode>[^\"]+)\""#).unwrap();
let string = "{\"line1\":\"1 THE STREET\",\"line2\":\"TOWN\",\"line3\":\"CITY\",\"line4\":null,\"postcode\":\"AB11AB\",\"country\":\"GREAT BRITAIN\",\"startDate\":944697600000,\"type\":\"Residential\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}