#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)PASSWORD\((?i)secret_?(?i)key\:["|'|`]?["|'|`]?\)"
Local $sString = "# Match this, double quotes included" & @CRLF & _
"PASSWORD(secret_key:"")" & @CRLF & _
"" & @CRLF & _
"# Match this, single quotes included" & @CRLF & _
"PASSWORD(secret_key:'')" & @CRLF & _
"" & @CRLF & _
"# Match this, back quote included" & @CRLF & _
"PASSWORD(SECRETKEY:``)" & @CRLF & _
"" & @CRLF & _
"# Match this, no quotes included" & @CRLF & _
"PASSWORD(SECRETKEY:)" & @CRLF & _
"" & @CRLF & _
"# No match, arrow brakets not included in pattern" & @CRLF & _
"PASSWORD(secretkey:<>)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")