$re = '/PASSWORD\((?i)secret_?(?i)key\:["|\'|`]?["|\'|`]?\)/m';
$str = '# Match this, double quotes included
PASSWORD(secret_key:"")
# Match this, single quotes included
PASSWORD(secret_key:\'\')
# Match this, back quote included
PASSWORD(SECRETKEY:``)
# Match this, no quotes included
PASSWORD(SECRETKEY:)
# No match, arrow brakets not included in pattern
PASSWORD(secretkey:<>)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);