import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "PASSWORD\\((?i)secret_?(?i)key\\:[\"|'|`]?[\"|'|`]?\\)";
final String string = "# Match this, double quotes included\n"
+ "PASSWORD(secret_key:\"\")\n\n"
+ "# Match this, single quotes included\n"
+ "PASSWORD(secret_key:'')\n\n"
+ "# Match this, back quote included\n"
+ "PASSWORD(SECRETKEY:``)\n\n"
+ "# Match this, no quotes included\n"
+ "PASSWORD(SECRETKEY:)\n\n"
+ "# No match, arrow brakets not included in pattern\n"
+ "PASSWORD(secretkey:<>)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}