const regex = /PASSWORD\((?i)secret_?(?i)key\:["|'|`]?["|'|`]?\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('PASSWORD\\((?i)secret_?(?i)key\\:["|\'|`]?["|\'|`]?\\)', 'gm')
const str = `# Match this, double quotes included
PASSWORD(secret_key:"")
# Match this, single quotes included
PASSWORD(secret_key:'')
# Match this, back quote included
PASSWORD(SECRETKEY:\`\`)
# Match this, no quotes included
PASSWORD(SECRETKEY:)
# No match, arrow brakets not included in pattern
PASSWORD(secretkey:<>)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}